Scroll

Why can't I install the game on my iPhone 4/iPod touch 4?

X-Mercs supports iPhone 5, iPad 3 and later. Older models, including iPhone 4 and iPod touch 4, are not compatible with the game.
Have more questions? Submit a request

Comments

Powered by Zendesk