Scroll

Why can`t I install the game on my iPad 1?

You can find the application requirements and the list of devices compatible stated at App Store in the information about the game. Please, note that Airport City HD is incompatible with iPad 1.
Have more questions? Submit a request

Comments

Powered by Zendesk