Scroll

Why can't I install the game on iPhone4/iPod 4?

Tank Domination game is supported on iPhones and iPods starting from 4s and the 5th generation models accordingly.
Note that iPhone 4, iPod Touch 4 and earlier versions are not supported.

Have more questions? Submit a request

Comments

Powered by Zendesk